Disclaimer: The information on this website is for education purposes only, and is not intended to replace the medical advice, diagnosis, or recommendations of your physician or healthcare provider. This site makes no claims that products, therapies, or services herein will cure disease. The views expressed on this website are those of our users. We may not share the same views.

Troubleshooting: Spooky2 Remote

Sometimes our users would come to us, and report that Remote LEDs are off or not on correctly. This could be from a false understanding of how Remote lights, to better understand this, please check the blog: http://www.spooky2-mall.com/blog/how-does-spooky-remote-light/

If it is not from false understanding, please do the trouble shooting following below instruction.

Situation 1 Neither of the Spooky remote LEDs is on.

Please follow these steps to troubleshoot.
Step 1 Please power off your generator and close the software. Turn on the generator first, then open the software. Choose >Miscellaneous>Signal Test (R) - DB preset, tick Allow Generator Overwrites, then open the channel to run the preset and check whether your remote lights or not. If this does not help, please go to Step 2.

Step 2 If your Spooky Remote LEDs don't light up, here are some steps you can follow to examine your Spooky Remote. Please check the link:
http://www.spooky2-mall.com/blog/spooky-remote-leds-do-not-light-up/

Step 3 If your remote still don't light, please take three pictures. First is the screenshot of the Control Tab on the software. Second is the picture of your generator display. Third is the picture of your remote connected to your generator. And send them to support@spooky2-mall.com. Our customer service would solve the problem for you.

Situation 2 Only one of the remote LED is on.

The possible cause is that the offset is 100% in a preset. If so, only one of the remote LEDs would light. It's normal. Please choose >Miscellaneous>Signal Test (R) - DB preset, tick Allow Generator Overwrites, then open the channel to run the preset. If both Remote LED light, this means your remote is good.

The other reason may be that you have set "Spooky central is always connected with Channel 3". If yes, please right click channel button and choose "no" to cancel it. Please check this QA for details: http://www.spooky2support.com/hc/en-us/articles/219297797

If still only one LED lights, please take three pictures. First is the screenshot of the Control Tab on the software. Second is the picture of your generator display. Third is the picture of your remote connected to your generator. And send them to support@spooky2-mall.com.

Our customer service would solve the problem for you.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.