Can I connect new Spooky Remote V.2.0 to old Spooky Boost (V 2.0)? And can I connect old Spooky Remote v 1.1 to new Spooky Boost 3.1?

Yes and yes.
No restrictions at all. Every device is compatible. I am still using the old boost cable, and also the oldest remotes.

For more details, please check the link:

Have more questions? Submit a request


Please sign in to leave a comment.