Here is the test result: Coils: output: 12VDC, frequency: 50 Hz, Waveform: Sinus Wave: 17.5 ms. Contact: output: 270VDC, frequency: 50 Hz, Waveform: Sinus Wave. Anything wrong with Spooky Central?

The coils and contact outputs are fixed at 100 Hz. There are no 50 Hz signals in Spooky Central apart from the mains frequency. In any case Spooky Central is digital, not sinusoidal. Spooky Central has no sine waves in the electronics. The 50 Hz signal would have been ground noise. Specially since it is not possible for any contact or coil output with the front control switch off.

The coil output is a 69uS spike which cannot be seen in a 20mS time scale which is commonly used for 50 Hz measurement. The contact output is even harder to see since it is ground-isolated and the spike is less than half a microsecond.

We have had several users say their units did not work, only to find that they used an oscilloscope that was not isolated from ground (i.e., USB powered or without an isolating transformer feed), did not know how to measure a biphasic signal, or had used a ground reference that was decoupled from the DC supply. The chassis is not a good point to use as electronic ground.

Can you please explain to your electronic engineer what I have just said, as he will understand. He will be able to test the unit properly.

If there are still concerns, please give clear and precise details of how you tested Spooky Central, with photos showing the test points (including the oscilloscope earth probe location) and oscilloscope screen.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.