Can you tell me what firmware number of UDB1108S? Are they the 4.2 that require the special Spooky software or the other standard ones?

Now the UDB1108S is Version 4.6. All UDB1108S are able to work together with Spooky2.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.